Uploaded image for project: 'XenServer Org'
  1. XenServer Org
  2. XSO-565

xenopsd internal error: Hotplug.Device_timeout(_)

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Done (View Workflow)
    • Priority: Major
    • Resolution: Done
    • Affects Version/s: 6.5 SP1
    • Fix Version/s: None
    • Component/s: Storage, VM Lifecycle
    • Labels:
      None
    • Environment:

      Description

      We encouter this error using Unitrends UEB solution.
      These appliances are made to backup VM hosted on a pool by attaching snapshots to them and copy data to backup disks.

      During the process, call are made to master by using API to attach snapshot of one VM to appliance.
      This fails with this error:
      ::80|VBD.plug R:63622cc172fd|xenops] Re-raising as INTERNAL_ERROR [ xenopsd internal error: Hotplug.Device_timeout(_) ]

      And so backups are failing.
      After many tests and tuning with UEB support, this seems to be a bug in XenServer 6.5SP1 (we have some UEB running on XS62 without problem).

      The last points we reached are:

      • Not related to network overload
      • Not related to storage IO overload
      • Attaching one snapshot to UEB appliance is fine but more will result on errors (concurrent backup)

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                jcastang Jerome Castang
              • Votes:
                0 Vote for this issue
                Watchers:
                4 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: