Uploaded image for project: 'XenServer Org'
  1. XenServer Org
  2. XSO-635

Wrong CPU Cores detection on Skylake processors

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Done (View Workflow)
    • Priority: Blocker
    • Resolution: Done
    • Affects Version/s: 6.5 SP1, 7.0, Ely alpha, 7.1, 7.2
    • Fix Version/s: None
    • Component/s: API, other
    • Labels:
      None
    • Environment:

      Mobo: Intel S1200SP
      Processor: Intel(R) Xeon(R) CPU E3-1230 v5 @ 3.40GHz
      Ram: 8GB
      Disk: 1TB (No RAID)
      SO: Xenserver 7

      Description

      I've been having this issue only with this processor/chipset. I can install XenServer, but when it boots doesn't recognize all the cores that it should be. The processor has 4 Physycal CPUs and it has Hyperthreading enabled on the BIOS (VT-d and VT-x also are activated), so it has 8 logical cores. Once installed /proc/cpuinfo shows 4 cores, and xl info show only one. In XenCenter, shows only one CPU available, and it generates the imposibility to give more than one core to a VM. There is a post on the forum that explains and gives more info of the problem: http://discussions.citrix.com/topic/381364-xen-detects-only-one-cpu/

      I'm referring this here because it's a very big issue for us, basically we cannot use Xenserver on this hardware, and it seems to be related to the Xen Kernel, but i cannot find any solution, and in the forum, i couldn't find any help. Bear in mind that almost all the hardware available right now belongs to the "Skylake" family, so this issue is a real blocker . I've tested this on 6.5 & 7 and it's the same, also another person tried it on "Ely" and doesn't seems to be solved.

        Attachments

        1. dmesg.txt
          55 kB
        2. dmesg-debian
          182 kB
        3. dmesg-debian
          82 kB
        4. hypervisor.log
          27 kB
        5. hypervisor.log
          15 kB
        6. putty.log
          29 kB
        7. xensource.log
          262 kB
        8. xen-xso-635-v1.gz
          995 kB
        9. xl-dmesg.log
          27 kB

          Activity

            People

            • Assignee:
              SimonCro Simon Crowe
              Reporter:
              gperez.tlp gperez.tlp
            • Votes:
              0 Vote for this issue
              Watchers:
              10 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: