Uploaded image for project: 'XenServer Org'
  1. XenServer Org
  2. XSO-665

VM suddenly shuts down and can't start

    Details

    • Type: Bug
    • Status: Done (View Workflow)
    • Priority: Major
    • Resolution: Done
    • Affects Version/s: 6.5 SP1
    • Fix Version/s: None
    • Component/s: VM Lifecycle
    • Labels:
      None
    • Environment:

      Xen Server 6.5 running on HP 380p Gen8 with BroadCom NetExtreme II BCM5719.
      All VM's stored in internal HP storage (5 TB).

      Description

      XenServer 6.5

      One of the VM suddenly shut down after 1 year running (uuid: 1aac0383-3417-87ec-3f35-07f724fa3d94) at 20:41:24

      Received an event on managed VM 1aac0383-3417-87ec-3f35-07f724fa3d94
      xenstore unwatch /local/domain/0/backend/vbd3/42/51744/kthread-pid
      Queue.push ["VM_check_state", "1aac0383-3417-87ec-3f35-07f724fa3d94"] onto 1aac0383-3417-87ec-3f35-07f724fa3d94:[  ]
      Queue.pop returned ["VM_check_state", "1aac0383-3417-87ec-3f35-07f724fa3d94"]
       Task 2242402 reference events: ["VM_check_state", "1aac0383-3417-87ec-3f35-07f724fa3d94"]
      xenstore unwatch /local/domain/0/backend/vbd3/42/51744/tapdisk-pid
      
      ...
      ...
      
      
       xenstore unwatch /local/domain/42/control
       xenstore unwatch /local/domain/42/device
       xenstore unwatch /local/domain/42/vm-data
       xenstore unwatch /vm/1aac0383-3417-87ec-3f35-07f724fa3d94/rtc/timeoffset
       VM.reboot 1aac0383-3417-87ec-3f35-07f724fa3d94
       Performing: ["VM_hook_script", ["1aac0383-3417-87ec-3f35-07f724fa3d94", "VM_pre_destroy", "hard-reboot"]]
       TASK.signal 2242402 (object deleted)
       Performing: ["VM_destroy_device_model", "1aac0383-3417-87ec-3f35-07f724fa3d94"]
       VM.destroy_device_model 1aac0383-3417-87ec-3f35-07f724fa3d94
       TASK.signal 2242402 (object deleted)
       Performing: ["VBD_unplug", ["1aac0383-3417-87ec-3f35-07f724fa3d94", "xvdb"], true]
       VBD.unplug 1aac0383-3417-87ec-3f35-07f724fa3d94.xvdb
       VM = 1aac0383-3417-87ec-3f35-07f724fa3d94; VBD = xvdb; Device is not surprise-removable (ignoring and removing anyway)
       Device.Generic.hard_shutdown_request frontend (domid=42 | kind=vbd | devid=51728); backend (domid=0 | kind=vbd3 | devid=51728)
      ...
      ...
      

      Attached: XenSource.log (660 KB)

      VM couldn't be started later because of error: "xenopsd internal Error: Hotplug.Device_timeout"
      There appeared as well in logs the "Dead Beef" issue.

      We had to restart server physically and then everything went OK.

      Related topics (not solved yet):

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              josebaez Jose baez
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: