Uploaded image for project: 'XenServer Org'
  1. XenServer Org
  2. XSO-668

XML for updates is broken

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Done (View Workflow)
    • Priority: Major
    • Resolution: Done
    • Affects Version/s: 6.5 SP1
    • Fix Version/s: None
    • Component/s: other
    • Labels:
      None

      Description

      Hi lads!

      Just to let you know, there is a 404 for some patches URL provided by the update XML (http://updates.xensource.com/XenServer/updates.xml)

      A quick example:

      <patch after-apply-guidance="restartHost" installation-size="20888508" name-description="Public Availability: Fix for Dom0 kernel" name-label="XS65ESP1005" patch-url="http://support.citrix.com/filedownload/CTX201514/XS65ESP1005.zip" releasenotes="" timestamp="2015-07-06T00:00:00Z" url="http://support.citrix.com/article/CTX201514" uuid="fe594bba-a0f7-4643-9429-8443d3a9e018" version="1.0">
      <!--  serverversion = '6.5.0'  -->
      <requiredpatches>
      <requiredpatch uuid="7f2e4a3a-4098-4a71-84ff-b0ba919723c7">
      <!--  XS65ESP1  -->
      </requiredpatch>
      </requiredpatches>
      </patch>
      
      

      Problem: this patch URL (http://support.citrix.com/filedownload/CTX201514/XS65ESP1005.zip) is giving a 404.

      It breaks both XenCenter patching and Xen Orchestra. I suspect this XML is not automatically generated (explaining the lag between a patch and the XML update) + some dead links sometimes.

        Attachments

          Activity

            People

            Assignee:
            Unassigned
            Reporter:
            olivierlambert Olivier Lambert
            Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: