Uploaded image for project: 'XenServer Org'
  1. XenServer Org
  2. XSO-775

Xenserver 7.2 network issues

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Done (View Workflow)
    • Priority: Major
    • Resolution: Fixed
    • Affects Version/s: 7.2
    • Fix Version/s: 7.5
    • Component/s: Networking
    • Labels:
      None
    • Environment:

      NetApp SAN serving up NFS storage

      Equallogic iSCSI SAN

      Cisco 2960 Gigabit Switch

      Broadcom and Intel NICs on Dell and HP servers

      We use 9000 byte jumbo frames on the interfaces that connect to our SANs.

    • Team:
    • Internal JIRA Reference:
      CA-288424

      Description

      The servers with broadcom NICs dropped offline sometime shortly after the upgrade to Xen 7.2.  Upon investigating, we found that the Cisco 2960 had blocked the port due to a loopback condition (keepalive packet being returned on the same port it was sent on).   The servers with Intel NICs did much better, but we saw the same thing happen with one of the Intel NICs that was connected to our Equallogic iSCSI SAN.   This seems to be a big problem and the Intel NICs just mask it better than the Broadcom NICs do. 

      We were running Xenserver 6.5 before upgrading to 7.2.   6.5 was completely stable for us with no such issues.   It seems as though the issues surface under heavy load.   

        Attachments

          Activity

            People

            Assignee:
            Unassigned
            Reporter:
            petelombardo Pete Lombardo
            Votes:
            8 Vote for this issue
            Watchers:
            28 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: