Uploaded image for project: 'XenServer Org'
  1. XenServer Org
  2. XSO-855

iSCSI SR volume group corrupted during snapshots

    Details

    • Type: Bug
    • Status: Done (View Workflow)
    • Priority: Major
    • Resolution: Duplicate
    • Affects Version/s: 7.3
    • Fix Version/s: None
    • Component/s: Storage
    • Labels:
      None
    • Environment:

      We are taking snapshots of running vm every night on a pool of 3 Xenservers 7.2 (fully patched) connected to 2 iscsi SR with multipath.

      Description

      Nighly snapshots of running vm are randomly corrupting iSCSI SR volume groups. When it happens, we need to restore volume group manually with 'vgcfgrestore'.

      It already happened 2 times this month :  

      Mar 14 22:19:56 xenserver08 SM: [31876] ***** LVHD over iSCSI: EXCEPTION <class 'SR.SROSError'>, The VDI is not available [opterr=Command ['/sbin/lvs', '--noheadings', '--units', 'b', '-o', '+lv_tags', '/dev/VG_XenStorage-6010cef0-b5ef-a604-bfd3-a1fde94d0d6f'] failed (5): /dev/disk/by-scsid/23237343363613338/mapper : Checksum error
      

       

      Mar 20 23:24:11 xenserver04 SM: [32119] ***** generic exception: vdi_delete: EXCEPTION <class 'SR.SROSError'>, Failed to load VDI [opterr=rvgstats failed error is 5]
      

       

      We have a second pool of XS 7.2 running exactly the same backup process on the same iscsi target model every night for one year now without any problem. This pool has only 2 nodes, I wonder if the problem could happen only on 3 nodes pool.

       

      Best regards,

      Nicolas Michaux

        Attachments

          Issue Links

            Activity

              People

              • Assignee:
                Unassigned
                Reporter:
                sarabanjina Nicolas Michaux
              • Votes:
                0 Vote for this issue
                Watchers:
                3 Start watching this issue

                Dates

                • Created:
                  Updated:
                  Resolved: