Uploaded image for project: 'XenServer Org'
  1. XenServer Org
  2. XSO-889

VM Metadata backup completes but fails to actually write to pooled SR DB

    Details

    • Type: Bug
    • Status: Done (View Workflow)
    • Priority: Major
    • Resolution: Won't Do
    • Affects Version/s: 7.3
    • Fix Version/s: None
    • Component/s: Storage, XenCenter
    • Labels:
      None
    • Environment:

      Xenerver 7.1 CU1 fully patched though 026, local SR and several pooled SRs, R720/R730 heterogeneous pool.

      Description

      When xsconsole is instructed to create a VM metadata backup on any given pooled SR (I tried on five different ones), it claims to complete successfully, yet if I go to check the backup list the new entry does not exist. There are old entries from a year ago, so something must have broken at some point a long time ago. If I run the backup and point to the local SR, it works. Also, if I try to schedule an automatic backup, it asks correctly if this is wanted daily, weekly, monthly, etc. but it does not ask onto which SR the VM metadata backup should be written.

      Is there a way to wipe out/re-create the DB on a given SR as something seems corrupt? I don't see this on any of my other pools that are also running XS 7.1 CU1.

      BTW, the backup should go to the default SR. I'm not sure what happens if a default SR has not been chosen!

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              tjkreidl Tobias Kreidl
            • Votes:
              0 Vote for this issue
              Watchers:
              3 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: