Uploaded image for project: 'XenServer Org'
  1. XenServer Org
  2. XSO-941

Network issues on VM in Xenserver 7.6

    Details

    • Type: Bug
    • Status: To Do (View Workflow)
    • Priority: Major
    • Resolution: Unresolved
    • Affects Version/s: 7.6
    • Fix Version/s: None
    • Component/s: Networking
    • Labels:
      None
    • Environment:

      Xenserver 7.6 on Two HP DL360 Gen9

      HP MSA 2052

      HP Aruba 2930F Switches

      Fortinet Fortigate 100D

      1GB multipath network

       

      Description

      I've noticed twice now on Xenserver where IP addresses are not route able without unplugging the Network adapter and re-attaching it. 

      Working example, I have a cpanel server which was created with an internal IP address of 10.0.0.52 with is routed to a public IP address via our firewall (NAT). The original address worked fine but we added in 2 IP addresses that were routed to another VM (cpanel again), migrated accounts from one machine to the other then disabled and removed them from the original server.

      When we ran the cpnat_rebuild tool cpanel was unable to route the IP, so we tested these from our switches and our firewall and none of the devices were able to route the IP address. After much testing and trying I shutdown the VM 3 or 4 times and still no luck. In the end i shutdown the machine and removed the network adapter in Xencentre and re-added it then the routing worked.

      We also noticed this with IPv6 as well on our zabbix monitoring tool when we tried to setup IPv6 on an existing IPv4 network.

        Attachments

          Activity

            People

            • Assignee:
              Unassigned
              Reporter:
              solidblueliquid Nathan Platt
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated: