Uploaded image for project: 'XenServer Org'
  1. XenServer Org
  2. XSO-773

Update of XS70E033 hangs while updating Pool

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Done (View Workflow)
    • Priority: Major
    • Resolution: Done
    • Affects Version/s: 7.1
    • Fix Version/s: None
    • Component/s: XenCenter
    • Labels:
      None
    • Environment:

      XenCenter 7.0.1.3852 (not 7.1!) and XenServer 7.0 with updates up to the hanging one.

      Description

      While trying to update the pool to XS70E033, it doesn't get, that our first server's XAPI is back up again.
      One of the last XSOs also had a problem with a similar situation.
      As to be seen on screenshot... you can wait forever, probably. I saved current XenCenter logs if it helps (can mail them to whoever)
      I manually made a reconnect, which let the right part of XenCenter show the Servers and everything fine again, but the left part was left 'dead' (disconnected).
      Can't remember from what, but I had that situation again, probably by some other previous of XAPI.

      Disconnecting the pool and connecting again helped to also let the left part show it correctly again, but the update window is still stuck with:
      ??Installing update XS70E033 to Midgard... done.
      Restarting agent in Midgard ... ??

      Important logfilepart is probably:
      ??2017-07-08 23:44:29,286 INFO XenAPI.Session [33] - Invoking XML-RPC method pool_patch.precheck
      2017-07-08 23:44:30,965 INFO XenAPI.Session [33] - Invoking XML-RPC method pool_patch.precheck
      2017-07-08 23:45:28,897 INFO XenAPI.Session [33] - Invoking XML-RPC method Async.pool_patch.apply
      2017-07-08 23:45:43,123 INFO XenAPI.Session [33] - Invoking XML-RPC method task.destroy
      2017-07-08 23:45:44,175 INFO XenAPI.Session [33] - Invoking XML-RPC method host.get_other_config
      2017-07-08 23:45:44,219 INFO XenAPI.Session [33] - Invoking XML-RPC method Async.host.restart_agent
      2017-07-08 23:45:56,109 WARN XenAdmin.Network.XenConnection [Connection to 192.168.101.14] - Lost connection to 192.168.101.14
      2017-07-08 23:45:56,116 INFO XenAPI.Session [Logging out session OpaqueRef:9f15a1f1-b08e-db4f-9604-c83583d16e24] - Invoking XML-RPC method session.logout??

      (Note: Your citation function is obviously broken)

        Attachments

          Activity

            People

            Assignee:
            Unassigned
            Reporter:
            cgiesers Christof Giesers
            Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: