Uploaded image for project: 'XenServer Org'
  1. XenServer Org
  2. XSO-767

vm migration fails after succesful upgrade (from 6.5 to 7.2)

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Done (View Workflow)
    • Priority: Critical
    • Resolution: Done
    • Affects Version/s: 7.2
    • Fix Version/s: None
    • Component/s: Installer
    • Labels:
      None
    • Environment:

      Description

      a) After a successful pool master upgrade, using the new partition schema, i tried to migrate a VM from the first slave to the pool master, using Xencenter.

      The "Migrate to Server" wizard can not proceed the operation because it "Cannot see required storage".

      • there is no migration option available, see attached image.

      b) Then i tried to migrate another VM using the CLI, the command failed.

       xe vm-migrate host=1f2a6c3b-fb14-4161-83aa-fa1729a1f525 vm=opencs

       "You attempted to run a VM on a host which doesn't have access to an SR needed by the VM. The VM has at least one VBD attached to a VDI in the SR."
      vm: 5b47b34e-fbe4-daa4-f187-072b8d154eec (opencs)
      sr: 4fbc4eda-d86e-43e9-1599-50613e71505a (Local storage)

      c) After shutting down the VM on the slave: Export (Failed to export) , Copy VM (INVALID_VALUE), Move VM (INVALID_VALUE).

      The VM cannot start with the error message "There were no servers available to start VM 'vmname'".

       

      The attached file contains the command output: xe host-list, xe sr-list, cat xensource.log

       

        Attachments

          Activity

            People

            Assignee:
            stephentu Stephen Turner
            Reporter:
            glekatsas George
            Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: