Uploaded image for project: 'XenServer Org'
  1. XenServer Org
  2. XSO-777

Permission issue on Windows 2012 R2 when calling VSS

    XMLWordPrintable

    Details

    • Type: Bug
    • Status: Done (View Workflow)
    • Priority: Major
    • Resolution: Done
    • Affects Version/s: 7.1
    • Fix Version/s: None
    • Component/s: API
    • Labels:
      None

      Description

      When calling quiesce snapshot, it fails (despite tools up to date and XS 7.1 with all patches applied). I'm sure the VSS service is up and works when calling it manually (from a Windows terminal).

      The only lead I have is an error in the Windows logs at the time when I ask a quiesce snapshot. When the VSS is called, it failed because of a permission issue (??!!). Error code are "error 13" or "error 12292".

      Is there anything to know to have VSS via Xen tools working regarding permissions on Windows? Both problematic VMs are running AD services.

        Attachments

        1. dbgview (1).pdf
          120 kB
          sharath Babu
        2. Screen Shot 2017-04-13 at 9.27.57 AM.png
          40 kB
          sharath Babu
        3. Screen Shot 2017-08-09 at 2.05.45 PM.png
          131 kB
          sharath Babu
        4. WIN-7PCTOAB7NAB.LOG
          20 kB
          sharath Babu

          Activity

            People

            Assignee:
            Unassigned
            Reporter:
            olivierlambert Olivier Lambert
            Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

              Dates

              Created:
              Updated:
              Resolved: